Как решить MySQL проблему «Failed to read auto-increment value from storage engine» при установке Wordpress?

Столкнулся с проблемой при установке Wordpress. Имеется Ubuntu-server + ISPConfig 3 версии. При попытке установки, выскакивает ошибка:
WordPress database error: [Failed to read auto-increment value from storage engine]

в error log выводит:
[Thu Sep 25 04:46:56.041541 2014] [:error] [pid 2103] [client ********] FastCGI: server "/var/www/clients/client1/web13/cgi-bin/php5-fcgi-*-80-domain.ru" stderr: PHP message: \xd0\x91\xd0\xb0\xd0\xb7\xd0\xb0 \xd0\xb4\xd0\xb0\xd0\xbd\xd0\xbd\xd1\x8b\xd1\x85 WordPress \xd0\xb2\xd0\xbe\xd0\xb7\xd0\xb2\xd1\x80\xd0\xb0\xd1\x82\xd0\xb8\xd0\xbb\xd0\xb0 \xd0\xbe\xd1\x88\xd0\xb8\xd0\xb1\xd0\xba\xd1\x83 Failed to read auto-increment value from storage engine \xd0\xb2 \xd0\xbe\xd1\x82\xd0\xb2\xd0\xb5\xd1\x82 \xd0\xbd\xd0\xb0 \xd0\xb7\xd0\xb0\xd0\xbf\xd1\x80\xd0\xbe\xd1\x81 INSERT INTO `wp_options` (`option_name`, `option_value`, `autoload`) VALUES ('sidebars_widgets', 'a:5:{s:19:\\"wp_inactive_widgets\\";a:0:{}s:9:\\"sidebar-1\\";a:6:{i:0;s:8:\\"search-2\\";i:1;s:14:\\"recent-posts-2\\";i:2;s:17:\\"recent-comments-2\\";i:3;s:10:\\"archives-2\\";i:4;s:12:\\"categories-2\\";i:5;s:6:\\"meta-2\\";}s:9:\\"sidebar-2\\";a:0:{}s:9:\\"sidebar-3\\";a:0:{}s:13:\\"array_version\\";i:3;}', 'yes') ON DUPLICATE KEY UPDATE `option_name` = VALUES(`option_name`), `option_value` = VALUES(`option_value`), `autoload` = VALUES(`autoload`), \xd0\xb2\xd1\x8b\xd0\xbf\xd0\xbe\xd0\xbb\xd0\xbd\xd0\xb5\xd0\xbd\xd0\xbd\xd1\x8b\xd0\xb9 wp_install, wp_install_defaults, update_option, add_option, referer: http://domain.ru/wp-admin/install.php?language=ru_RU

бродил на форумах mysql, так и ответа не получил. Советовали переустановить - переустановил(apt-get install -reinstall mysql-server). Не помогло.
  • Вопрос задан
  • 3130 просмотров
Пригласить эксперта
Ответы на вопрос 1
HeadOnFire
@HeadOnFire Куратор тега WordPress
PHP, Laravel & WordPress Evangelist
Проблема 100% на уровне MySQL, WordPress тут вообще ни при чем. Простая переустановка не факт что поможет. С обычным MySQL давно не работаю, советую сделать то же самое - установить MariaDB 10 (и модуль php-mysqlnd понадобится).

1. Здесь выбираем свою версию убунты и MariaDB, полученные данные добавляем в список репо
2. Удаляем MySQL
3. Устанавливаем MariaDB и php-mysqlnd
4. Делаем mysql_secure_install
5. Профит
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
22 нояб. 2019, в 09:36
40000 руб./за проект
22 нояб. 2019, в 09:30
70000 руб./за проект