gordon_shamway
@gordon_shamway

Как устранить ошибку microsoft visual c++ 10.0 is required (unable to find vcvarsall.bat)?

При установке модуля lxml выскакивает ошибка microsoft visual c++ 10.0 is required (unable to find vcvarsall.bat), побывал установить visual studio не помогло, как ее можно решить?
Python 3.4.3 32bit
Windows 7
при установке установились Microsoft Visual Studio 9.0 и Microsoft Visual Studio 14.0
файл vcvarsall.bat есть в Microsoft Visual Studio 14.0
  • Вопрос задан
  • 7390 просмотров
Решения вопроса 2
@Andy_U
Запомните url: www.lfd.uci.edu/~gohlke/pythonlibs, где вы найдете уже скомпилированный модуль/пакет для вашей версии питона и разрядности, скачаете его и инсталлируете командой pip install file .whl (lxml там точно есть).
Ответ написан
dimonchik2013
@dimonchik2013
жизнь прекрасна в Амстердаме, а в Воронеже gаvно
можете попробовать решить вот так или вот так

но с вероятностью 90% не решите никак - третья категория Python модулей: для компиляции требует еще подключаемых/компилируемых библиотек (libxml2 etc.)
если бы это было на винде просто - не было бы проблемы с 64битными win модулями,
а их, как известно, сейчас очень очень мало
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@grezzzle
1) Сначала необходимо обновить setuptools "pip install setuptools --upgrade"
2) Установить landinghub.visualstudio.com/visual-cpp-build-tools
3) Скачать и установить lxml отсюда www.lfd.uci.edu/~gohlke/pythonlibs pip install "имя пакета"
профит
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
23 сент. 2019, в 12:29
3000 руб./за проект
23 сент. 2019, в 12:09
20000 руб./за проект
23 сент. 2019, в 12:08
30000 руб./за проект