Tomasina
@Tomasina
Инженер-разработчик

Hастроить два монитора в Linux?

Помогите новичку в Linux. Установил openSUSE 12.2 (x86_64) KDE: 4.8.


Железо:

Видеокарта nVidia GeForce 7300 GS, выходы DVI и DVI.

Мониторы Samsung SyncMaster 940N, один подключен по DVI, второй через переходник к DSUB.


Нужно разрешение 1280x1024 на обеих мониторах, расширенный рабочй стол (не клон)


В «Параметры системы» — «Экран» — «Разрешение и ориентация» есть два монитора, но у одного почему-то максимальное разрешение 1280х1024, а у второго 1024х768, хотя сами мониторы абсолютно одинаковые.


пробовал через xrandr:
linux-4b34:/home/tomasina # xrandr
Screen 0: minimum 8 x 8, current 2560 x 1024, maximum 4096 x 4096
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+
   800x600        72.2     60.3     56.2  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4    120.6    112.7  
   320x240       120.1  
DVI-I-0 connected 1280x1024+1024+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
TV-0 disconnected (normal left inverted right x axis y axis)

linux-4b34:/home/tomasina # xrandr --newmode "1280x1024_60"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

linux-4b34:/home/tomasina # xrandr --newmode "1280x1024_60.0"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

linux-4b34:/home/tomasina # xrandr --addmode VGA-0 "1280x1024_60"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  154 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32


В чем ошибка?

Читал это wiki.archlinux.org/index.php/Xrandr#Adding_undetec... и подобное, решения не нашел.


Пошел другим путем — внес изменения в /etc/X11/xorg.conf.d/50-screen.conf (насколько смог разобраться):
Section "Device"
  Identifier "nvidia"  
  Driver         "nvidia"
  VendorName     "NVIDIA Corporation"
  BoardName      "GeForce 7300 GS"
  Option "VGA-0" "Monitor0"
  Option "DVI-I-0" "Monitor1"
EndSection

Section "Monitor"
  Identifier "Monitor0"
  Option     "PreferredMode" "1280x1024"
EndSection

Section "Monitor"
  Identifier "Monitor1"
  Option     "PreferredMode" "1280x1024"
  Option     "RightOf"   "Monitor0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device "nvidia"
  Monitor "Monitor0"
  DefaultDepth  24
  SubSection "Display"
    Virtual 2560 1024
  EndSubSection
EndSection


После перезагрузки эффекта нет, визуально ничего не изменилось, новые разрешения не добавились.
  • Вопрос задан
  • 25030 просмотров
Решения вопроса 1
Tomasina
@Tomasina Автор вопроса
Инженер-разработчик
Поменял кабель, все заработало с первого пинка. Вот так живешь в век цифровой техники, а танцуешь иногда с бубном не там, где собака порылась.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
Lerg
@Lerg
Defold, Corona, Lua, GameDev
Надо настраивать через утилиту nvidia.
Ответ написан
mikes
@mikes
проблема в том, что через переходник не получается считать EDID монитора и соотв понять его параметры
что то вроде
Option «CustomEDID» «DVI-I-0:/etc/X11/edid.bin»
поможет исправить ситуацию
ну понятно, что edid сначала надо сохранить в файлик (вроде это можно сделать через nvidia-settings)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы