Как проще всего проверить код на работу в php 5.0?

Два часа пытался скомпилировать 5.0.5 из исходников. С большим трудом сделал-таки configure, но make упал с ошибками... На той же машине 5.6.19 собирается без проблем. Видимо, какие-то несовместимые версии чего-то с чем-то, но уже нет сил дебажить.

В идеале, нужна виртуальная машина или образ для vagrant или какой-нибудь пыльный ppa-репозитрий для Ubuntu - ничего не могу нагуглить.

Единственное, что нашёл - sandbox.onlinephpfunctions.com, но там куча функций отключена в целях безопасности, толком не проверить.

В качестве запасного варианта подойдёт и какой-нибудь статический линтер, тоже ничего не могу найти (может, какая-то очень старая версия PhpStorm?).

P.S. PHP 5.0 увидел свет 13 июля 2004 года, снят с поддержки десять с половиной лет назад. Но, бизнес диктует свои условия...

UPD: Ещё есть piliapp.com/php-syntax-check, но там нет 5.0 и 5.1, хотя есть 4.4.
  • Вопрос задан
  • 291 просмотр
Пригласить эксперта
Ответы на вопрос 2
Melkij
@Melkij
PostgreSQL DBA
Для сборки 5.0 в современном окружении надо накатить пару патчей:
Поддержка libxml2 https://github.com/hnw/phpall/blob/master/patches/...
Поддержка openssl: https://github.com/hnw/phpall/blob/master/patches/...
Не обращайте внимание на 5.1.6 в имени, патчи подходят для 5.0.5

Из начального состояния "5.6 собирается", под debian 8 нужен ещё пакет flex-old. Всё, других манипуляций при сборке я не делал, в остальном php собрался штатно и вроде бы работает.

Disclaimer: я не старый извращенец и некромант, просто как-то грустным зимним вечером захотелось погреться и собрать по последнему представителю всех веток 5.х =)
Ответ написан
Maronus
@Maronus
Если не хочется заморачиваться со сборкой из исходников, то посоветовал бы:
  1. Docker — можете создать хоть десяток контейнеров с любой версией PHP, при этом с немалой экономией ресурсов и времени в отличие от обычных виртуалок или vagrant.
  2. Репы старых пакетов Debian. Debian Lenny в Docker Hub найти можно, хотя может и на современные версии эти пакеты встанут - не знаю.
  3. Установка примерно такая: apt-get install php5=5.3.3-7+squeeze3
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы