webirus
@webirus
Тыжверстальщик! Наверстай мне упущенное...

Хочу собрать нормальный gulpfile.js, какие плагины вы используете?

Хочу настроить нормально наконец-то gulpfile.js.
Но застопорился на выборе плагинов из-за обилия таковых)))
Какие вы используете в работе и почему?
  • Вопрос задан
  • 685 просмотров
Решения вопроса 4
zorro76
@zorro76
front-end
вот полный перечень, а почему? это сложилось со временем, почитать о них можно в нете.
gulp = require('gulp'),
sass = require('gulp-ruby-sass'),
autoPrefixer = require('gulp-autoprefixer'),
cleanCSS = require('gulp-clean-css'),
uglify = require('gulp-uglify'),
minifyHTML = require('gulp-minify-html'),
imageMin = require('gulp-imagemin'),
pngquant = require('imagemin-pngquant'),
 jsHint = require('gulp-jshint'),
concat = require('gulp-concat'),
cache = require('gulp-cache'),
del = require('del'),
gulpFilter = require('gulp-filter'),
mainBowerFiles = require('main-bower-files'),
connect = require('gulp-connect'),
gulpIf = require('gulp-if'),
util = require('gulp-util'),
plumber = require('gulp-plumber'),
rigger = require('gulp-rigger'),
spritesmith = require('gulp.spritesmith'),
size = require('gulp-size'),
opn = require('opn');
Ответ написан
Serj-One
@Serj-One
i'm sexy and i know it
"devDependencies": {
    "browser-sync": "^2.18.8",
    "gulp": "^3.9.1",
    "gulp-autoprefixer": "^3.1.1",
    "gulp-concat": "^2.6.1",
    "gulp-csscomb": "^3.0.8",
    "gulp-csso": "^2.0.0",
    "gulp-newer": "^1.3.0",
    "gulp-plumber": "^1.1.0",
    "gulp-rigger": "^0.5.8",
    "gulp-sass": "^3.1.0",
    "gulp-tinypng": "^1.0.2",
    "gulp-uglify": "^2.0.1",
    "gulp-watch": "^4.3.11"
  }

В зависимости от проекта список может расширятся, но костяк таков.
Ответ написан
delphinpro
@delphinpro Куратор тега CSS
frontend developer
Вариант 1
"devDependencies": {
    "browser-sync": "^2.17.1",
    "del": "^2.2.2",
    "gulp": "^3.9.1",
    "gulp-autoprefixer": "*",
    "gulp-changed": "^1.3.2",
    "gulp-changed-in-place": "^2.0.3",
    "gulp-cssnano": "^2.1.2",
    "gulp-data": "^1.2.1",
    "gulp-if": "^2.0.1",
    "gulp-imagemin": "^3.0.3",
    "gulp-notify": "^2.2.0",
    "gulp-rename": "^1.2.2",
    "gulp-rigger": "^0.5.8",
    "gulp-sass": "^2.3.2",
    "gulp-sequence": "^0.4.6",
    "gulp-sourcemaps": "^1.6.0",
    "gulp-twig": "^0.5.0",
    "gulp-uglify": "^2.0.0",
    "require-dir": "^0.3.1"
  }


Вариант 2
"devDependencies": {
    "autoprefixer": "^6.5.3",
    "babel-core": "^6.18.2",
    "babel-loader": "^6.2.8",
    "babel-preset-es2015": "^6.18.0",
    "babel-preset-stage-0": "^6.16.0",
    "browser-sync": "^2.18.2",
    "css-loader": "^0.26.0",
    "del": "^2.2.2",
    "extract-text-webpack-plugin": "^1.0.1",
    "file-loader": "^0.9.0",
    "gulp": "^3.9.1",
    "gulp-autoprefixer": "^3.1.1",
    "gulp-changed": "^1.3.2",
    "gulp-changed-in-place": "^2.0.3",
    "gulp-concat": "^2.6.1",
    "gulp-if": "^2.0.2",
    "gulp-imagemin": "^3.1.1",
    "gulp-notify": "^2.2.0",
    "gulp-rename": "^1.2.2",
    "gulp-sass": "^2.3.2",
    "gulp-sequence": "^0.4.6",
    "gulp-sourcemaps": "^1.9.1",
    "gulp-util": "^3.0.7",
    "node-sass": "^3.13.0",
    "require-dir": "^0.3.1",
    "sass-loader": "^4.0.2",
    "style-loader": "^0.13.1",
    "webpack": "^1.13.3",
    "webpack-stream": "^3.2.0"
  },
Ответ написан
LucasKane
@LucasKane
Front-end Developer
Вот еще вариант
"devDependencies": {
        "gulp": "^3.9.1",
        "gulp-bower": "^0.0.13",
        "gulp-postcss": "^6.0.0",
        "gulp-clean-css": "^2.0.7",
        "gulp-rigger": "^0.5.8",
        "gulp-sass": "^2.3.1",
        "gulp-watch": "^4.3.5",
        "gulp-filter": "^4.0.0",
        "gulp-csscomb": "^3.0.8",
        "gulp-plumber": "^1.1.0",
        "gulp-util": "^3.0.8",
        "gulp-zip": "^4.0.0",
        "gulp-posthtml": "^2.0.0",
        "autoprefixer": "^6.0.0",
        "browser-sync": "^2.12.5",
        "rimraf": "^2.5.2",
        "eslint": "^3.9.1",
        "eslint-config-yandex": "^1.0.6",
        "posthtml-attrs-sorter": "^1.1.0"
    }
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Sveak Барнаул
от 50 000 руб.
Oprosso Тверь
от 60 000 до 130 000 руб.
Девять линий Ульяновск
от 45 000 до 80 000 руб.
26 июн. 2019, в 20:56
10000 руб./за проект
26 июн. 2019, в 20:44
3000 руб./за проект
26 июн. 2019, в 19:34
300 руб./за проект