@dagand-ansh
Инженер-программист (веб-разработка)

Стоит ли использовать symfony 4 в разработках?

На данный момент разрабатываю на symfony 3.4 (LTS)
Стоит ли в новых проектах использовать symfony 4 ?
Или все же и дальше использовать 3.4 LTS версию до следующего релиза LTS (4.4) ?
  • Вопрос задан
  • 506 просмотров
Решения вопроса 2
Stalker_RED
@Stalker_RED
.
current version
4.0.3
recommended to create new Symfony projects

https://symfony.com/roadmap

Скорее всего, перейти на 4.* LTS можно будет без особых проблем.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@dizzy7
Вспоминая переход на 3-ю версию - основная проблема это поддержка бандлов. Для нашего проекта пришлось ждать больше года, пока все обновились. Подозреваю что с четвёркой будет похожая ситуация.
Ответ написан
@Kolarian
Сам перехожу на 4 версию. И столкнулся с множеством проблем. Популярные пакеты типо FOSUserBundle, KNPMenuBundle пока что не поддерживаются. WhiteOctober Breadcrumbs тоже. Но это все терпимо. Но реальная проблема в другом. Больше нет doctrine:generate:entity - entities, doctrine:generate:crud . А это означает, что создание обычного CRUD для сущности со скажем 5-6 значениями и к этому связами ManyToOne или ManyToMany займет в 20-30 раз больше времени. Я сегодня проверял, то, над чем я пыхтел почти 8 часов, на версии 3.4 я сделал за 20-25 минут. Разница колоссальная. Разработчики кричат что пора перестать использовать анемический код, но альтернативы ему никто не предлагает. Вот моя короткая рецензия...
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы