BonBonSlick
@BonBonSlick
Vanilla Full Stack Web Architector

Packages any Symfony project must have?

Какие пакеты Symfony 4 mast have?
И какие пакеты Symfony 3 mast have?
А еще, какие пакеты Symfony 2 и ниже mast have?
  • Вопрос задан
  • 268 просмотров
Пригласить эксперта
Ответы на вопрос 2
@FanatPHP
Все усилия Фабьена в течение последних лет были направлены на то, чтобы в принципе уничтожить такое понятие, как must have packages.
И Symfony 4 как раз и является плодом этих усилий.

Вариантов применения фреймворка бесконечное количество. Если у нас JSON API, то ему не нужен Twig и Form. Если это набор консольных утилит, то не нужен validator. И так далее.

Если речь о "стандартном" веб-сайте, то вот набор, предлагаемый по умолчанию: https://github.com/symfony/website-skeleton/blob/4...

И я искренне не понимаю, почему в вопросе упомянуты 3 и 2 версии.
Начинать сегодня проект на Симфони 3 это все равно что покупать лошадь с телегой вместо автомобиля.
Ответ написан
@Minifets
Я бы сказал так, минимум, который должен быть во всех проектах (csrf, xss, sql injection) уже включен в standard edition пакет symfony. Все остальное на усмотрение требований к проекту.
Например таже самая captcha на login form, может показаться must have, но в некоторых проектах она будет избыточной и не нужной.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы