@dsolomon

Как решить проблему с модулем для yii2 notgosu/yii2-i18n-module?

В проекте используется модуль notgosu/yii2-i18n-module
Проблема в том, что проект не разворачивается потому что данный модуль пытается установить еще один модуль, которого уже нет на github.
Как перейти на использование модуля zelenin/yii2-i18n-module вместо notgosu/yii2-i18n-module.
Спасибо!
  • Вопрос задан
  • 62 просмотра
Пригласить эксперта
Ответы на вопрос 2
webinar
@webinar
Учим yii2: https://youtu.be/-WRMlGHLgRg
Проблема в том, что проект не разворачивается потому что данный модуль пытается установить еще один модуль, которого уже нет на github.

клонируете себе, убираете зависимость от мертвого модуля, устанавливаете себе. Я не знаю о какой мертвой зависимости речь, но может оказаться, что там какой-то простой хелпер и можно написать свой велосипедик, что бы модуль завелся без этой зависимости.

Как перейти на использование модуля zelenin/yii2-i18n-module вместо notgosu/yii2-i18n-module.

Вы думаете есть волшебная команда, которая перебирает Ваш код и магически переписывает его под использование других классов, с другими методами и т.д. Что Вы ожидаете увидеть?
Ответ написан
@karminski
Разработчик CRM/ERP систем
Использую в качестве модуля i18n вот это
"omgdef/yii2-multilingual-behavior"
Настраивается просто и работает на всех моих проектах.

Модуль давно не обновлялся. Но, может быть, там нечего обновять :)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы