@Brunetgk

"postcss" не является внутренней или внешней командой. Не запускается команда postcss. Как быть??

Изучаю БЭМ. Устанавливал postcss, согласно обучающему курсу на Ютубе.

npm i  browser-sync --save-dev
                browser-sync start --server --files 'style.css'


Создавал конфижки необходимые и все было хорошо, но когда я дошел до

postcss style.post.css -o style.css

Мне выдало:
"postcss" не является внутренней или внешней
                   командой, исполняемой программой или пакетным файлом.


Не знаю, почему.
Единственный момент при установке postcss и плагинов (npm i postcss-cli autoprefixer postcss-nested --save-dev) мне выходит следующее:

npm WARN bem@1.0.0 No description
npm WARN bem@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})


Вроде как уведомление о необязательных вещах, но все же.
Помогите пжл запустить команду postcss.
  • Вопрос задан
  • 77 просмотров
Решения вопроса 1
@kacheleff
fullstack developer
пакет postcss-cli нужно установить глобально
npm i -g postcss-cli
флаг -g как раз означает глобальную установку
при глобальной установке в консоли становится доступной команда postcss
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы