Bandicoot
@Bandicoot
Программирование == Инженерное дело

Как настроить VS Code на работу с пакетами Composer?

Перешел на этот замечательный редактор с NetBeans. В этой IDE был автокомплит по установленным в папку vendor пакетам: пишешь в начале файла use ... и среда разработки автоматически подгружает в выпадающем списке нужные пакеты. Но VS Code по умолчанию такое не умеет. Как научить, какое расширение поставить?
  • Вопрос задан
  • 135 просмотров
Решения вопроса 1
Bandicoot
@Bandicoot Автор вопроса
Программирование == Инженерное дело
Временно решил проблему следующим образом:

1. Установил это расширение: https://marketplace.visualstudio.com/items?itemNam...
2. Далее при получении объекта нужного мне класса, например $picker = new DatePicker();
кликаю по имени класса правой кнопкой мыши и выбираю Import Class. В начале файла под неймспейсом импортируется новый класс с помощью оператора use.

Это не очень удобно, надеюсь в будущем найду лучшее решение.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@balamyt92
; select * from users; --
Возможно этот плагин поможет https://marketplace.visualstudio.com/items?itemNam... но сомневаюсь что можно будет дотянуть до NetBeans
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы