@Econavi

Не могу установить gulp-image (gulp-imagemin), в чем может быть проблема?

Раньше всё устанавливалось, но сейчас уже нет.
Пробовал удалять и устанавливать node.js с npm.
Пробовал с SUDO и без него.
Пробовал установить аналогичные пакеты — gulp-imagmin, gulp-image-optimization
Постоянно вылетает ошибка.
Решение нагуглить не удается.
В чем может быть дело?

Другие пакеты устанавливаются нормально.

MacBook-Air:t5 Acrob$ sudo npm i -D gulp-image
npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5

> gifsicle@3.0.4 postinstall /Users/Acrob/t5/node_modules/gifsicle
> node lib/install.js

  ⚠ EACCES: permission denied, mkdir '/Users/Acrob/t5/node_modules/gifsicle/vendor'
  ⚠ gifsicle pre-build test failed
  ℹ compiling from source
/Users/Acrob/t5/node_modules/onetime/index.js:15
				throw new Error(fnName + ' can only be called once.');
				^

Error: callback() can only be called once.
    at onetime (/Users/Acrob/t5/node_modules/onetime/index.js:15:11)
    at /Users/Acrob/t5/node_modules/download/index.js:156:5
    at ConcatStream.<anonymous> (/Users/Acrob/t5/node_modules/concat-stream/index.js:36:43)
    at emitNone (events.js:111:20)
    at ConcatStream.emit (events.js:208:7)
    at finishMaybe (/Users/Acrob/t5/node_modules/readable-stream/lib/_stream_writable.js:620:14)
    at endWritable (/Users/Acrob/t5/node_modules/readable-stream/lib/_stream_writable.js:628:3)
    at ConcatStream.Writable.end (/Users/Acrob/t5/node_modules/readable-stream/lib/_stream_writable.js:584:41)
    at DuplexWrapper.onend (/Users/Acrob/t5/node_modules/readable-stream/lib/_stream_readable.js:577:10)
    at Object.onceWrapper (events.js:313:30)
npm WARN t5@1.0.0 No description
npm WARN t5@1.0.0 No repository field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! gifsicle@3.0.4 postinstall: `node lib/install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the gifsicle@3.0.4 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/Acrob/.npm/_logs/2018-02-22T14_34_36_143Z-debug.log
  • Вопрос задан
  • 202 просмотра
Пригласить эксперта
Ответы на вопрос 2
vkotliar
@vkotliar
Frontend spirit
В комментарии выше верно отмечено, что у текущего пользователя нет рут прав.

Соответственно, нужно проверить права и тогда судо будет работать корректно.
Ответ написан
@Econavi Автор вопроса
Я не знаю что это, но помогло оно:
npm config set unsafe-perm=true
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы