Как в Excel удалить неполные дубли?

Есть таблица Excel. В ней в некоторых строках значения одного столбца почти одинаковы (отличаются только 1-2 символа в конце). Как сделать так, чтобы можно было удалить строки, в которых они находятся? Ну или хотя бы пометить их, чтобы их было сразу видно.
  • Вопрос задан
  • 85 просмотров
Пригласить эксперта
Ответы на вопрос 1
bopoh13
@bopoh13
VBA, analytic, Ruby (noob)
Можно пометить записи через условное форматирование, как написал DS28.

В Excel 2007 и выше для диапазона $A:$A выделение повторяющихся значений производится формулой =СЧЁТЕСЛИ($A:$A;$A1)>1.
Если нужно сравнивать строки без последних 2-х символов, то формула будет =СЧЁТЕСЛИ($A:$A;ЛЕВСИМВ($A1;ДЛСТР($A1)-2)&"??")>1, но при условии, что у них одинаковая длина.

Если в конце может быть 1 или 2 символа, то можно искать тире справа перед 2-мя последними символами:
=СЧЁТЕСЛИ($A:$A;ЛЕВСИМВ($A1;ПОИСК("-";$A1;ДЛСТР($A1)-2))&"*")>1
Но если вдруг тире в записи не окажется - неизбежна ошибка, поэтому нужно будет добавить исключение:
=СЧЁТЕСЛИ($A:$A;ЕСЛИОШИБКА(ЛЕВСИМВ($A1;ПОИСК("-";$A1;ДЛСТР($A1)-2))&"*";ЛЕВСИМВ($A1;ДЛСТР($A1)-2)&"??"))>1

ЗЫ: Если какие-то варианты я упустил, то вы их не описали.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы
Getblogger Москва
от 150 000 до 200 000 руб.
Digital Contact Москва
До 50 000 руб.
ZAVOD Games Москва
До 70 000 руб.
19 авг. 2018, в 12:12
40000 руб./в месяц
19 авг. 2018, в 11:19
5000 руб./за проект
19 авг. 2018, в 10:09
1000 руб./за проект