BonBonSlick
@BonBonSlick
Vanilla Full Stack Web Architector

This package requires php ^7.2.2 but your PHP version (7.1.9)?

vagrant@homestead:~$ php -v
PHP 7.2.2-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Feb  1 2018 16:01:26) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.2-1+ubuntu16.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies
    with Zend Server Z-Ray v9.2.0, Copyright (c) 2004-2017, by Zend Technologies
    with blackfire v1.18.2~linux-x64-non_zts72, https://blackfire.io, by SensioLabs


composer.json
"require": {
        "php": "^7.2.2",


ERROR
$ composer install
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - This package requires php ^7.2.2 but your PHP version (7.1.9) does not satisfy that requirement.


Vagrant обновил, и Homestead, там уже есть версия php 7.2, composer.lock удалял.

Почему выкидывать еще может ошибку, скажите пожалуйста?
  • Вопрос задан
  • 152 просмотра
Решения вопроса 1
Maksclub
@Maksclub
maksfedorov.ru
возможно еще проблема в .env
*судя по советам на Github
https://github.com/laravel/framework/issues/20214#...
https://github.com/laravel/framework/issues/20214#...

Homestead и PHP 7.2 на борту
Сталкивался там с таким поведением — стоит по умолчанию 7.2, но по факту 7.1
Попробуйте зайти в виртуалку и сменить в ручную версию PHP
sudo update-alternatives --config php
будет предложен пронумерованный список альтернатив (в частности, с указанием пути к реальным файлам) с предложением ввести номер (из списка) для изменения текущего выбора альтернативы, ну и PHP-FPM перезапустить

Если прокатит этот вариант, то нужно будет добавить команду в after.sh и написать разрабам что-ли...
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы