@hovdev

Сurl 7.29 работает с tls v1.2?

Всем привет, есть один странный момент, читаю в документации что curl поддерживает протокол tls v1.2 с версии 7.34
--tlsv1.2
(TLS) Forces curl to use TLS version 1.2 or later when connecting to a remote TLS server.
Added in 7.34.0.


Но несмотря на это, когда я делаю запрос вида
curl --tlsv1.2 https://tlstest.paypal.com/

или через php
php -r '$ch = curl_init(); curl_setopt($ch, CURLOPT_URL, "https://tlstest.paypal.com/"); curl_setopt($ch, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1_2); var_dump(curl_exec($ch)); var_dump(curl_error($ch));'

Результат всегда успешный
PayPal_Connection_OK
bool(true)


Суть вопроса в том, 7.29 поддерживает подключение через tls v 1.2 или нет ?
Если нет, то почему это у меня работает ?
т.к если работает то я не буду обновлять и делать лишние действия на сервере.
  • Вопрос задан
  • 63 просмотра
Пригласить эксперта
Ответы на вопрос 2
@ky0
Миллиардер, филантроп, патологический лгун
Вы скопипастили из мана ключ, который принудительно заставляет использовать TLS 1.2. Никто не говорит, что его поддержка была добавлена именно в этой версии. Ещё, разумеется, зависит от библиотеки, которая используется для работы с SSL.
Ответ написан
@MechanID
Админ хостинг провайдера
в консоли сервера сделайте curl -v https://tlstest.paypal.com/
ищите строчку "SSL connection using"
у меня например SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
смотрите что у вас и все будет ясно.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы
12 дек. 2018, в 08:07
1000 руб./за проект
12 дек. 2018, в 05:58
1000 руб./за проект
11 дек. 2018, в 21:41
500 руб./за проект