@Rentable
Инженер

Почему через некоторое время пропадает мультикаст IPTV?

Создал радиомост из: SXT HG5 (RBSXTG-5HPnD-HGr2) и Light Head Grid (LHG 5)
Режим - прозрачный бридж. На одном конце подключается к выходу порта коммутатора FTTB, на другом конце - IPTV приставка от Ростелеком.
При подключении приставки напрямую в порт - показывает безупречно, при использовании радиомоста - вещание прекращается примерно минуты через 1- 3, картинка замирает.
Если воспользоваться перемоткой (как понимаю, режим меняется на юникаст и формат потока меняется на HLS), - отмотать чуть назад, то работает всё прекрасно.
Конфигурацию прилагаю, настройка минимальная, включил multicast-helper=full
IGMP proxy не устанавливал, т.к. требуется именно прозрачный мост. На другом конце стоит камера (тоже от Ростелекома) и шлёт поток в обратную сторону. Камера работает.
Как понимаю, приставка должна периодически слать какой то пакет серверу вещания, что она живая и канал смотрят, но как это сделать?
Конфигурация
# oct/22/2018 15:16:04 by RouterOS 6.43.4
# software id = TDDB-5LU8
# model = RouterBOARD LHG 5nD
# serial number = 6FххххB81067
/interface bridge
add fast-forward=no igmp-snooping=yes name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-onlyn channel-width=20/40mhz-XX \
    disabled=no frequency=auto frequency-mode=superchannel mode=\
    station-bridge multicast-helper=full nv2-preshared-key=хххqBff2M \
    nv2-security=enabled radio-name=ASAD_st ssid=ASAD_br_AP \
    wireless-protocol=nv2
/interface ethernet
set [ find default-name=ether1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 hw=no interface=ether1
add bridge=bridge1 interface=wlan1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Moscow
/system routerboard settings
set silent-boot=no
  • Вопрос задан
  • 222 просмотра
Решения вопроса 1
@Rentable Автор вопроса
Инженер
Решил упростить задачу. Взял Микротик haplite, сбросил конфигурацию, 3 и 4 порт установил в бридж. 3 порт вставил в коммутатор FTTB, 4 порт - в приставку. Картина и дамп всё те же, картинка встаёт примерно через минуту. После переключения каналов - трансляция благополучно продолжается.
Перечитал ещё раз "Сети для самых маленьких. Часть девятая. Мультикаст" на хабре. Нашёл статью с информацией, которой нет в "сетях для маленьких" - "Оптимизация передачи multicast-трафика в локальной сети с помощью IGMP snooping" на том же хабре.
Проблема решилась:
Отключил IGMP snooping, присвоил bridge1 mac адрес вручную (несуществующий), отключил STP, и в настройках всех портов в составе бриджа убрал галочки как на скриншоте. Всё заработало.
5bd06be629077161708015.png
Всем спасибо за участие!
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
martin74ua
@martin74ua
Linux administrator
igmp у вас не работает
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы