@tuxx

Правда что Android 6 и выше требуют GPS для bluetooth?

Приложение для напольных весов PICOOC стало требовать подключения GPS для работы с bluetooth. Иначе соединения не происходит и весы превращаются в совершенно обычные напольные. От обиды написал производителю и получил ответ что якобы так требует сам android. Они ссылаются на эту страницу документации, но я не увидел ничего похожего (с английским плоховато. учу). В качестве решения предлагают ставить android 5.

Текст ответа мне

Hi, Sergey
I am very sorry for the inconvenience. We understand your mood, but please listen to our explanation.

About location permission
1. Google requires all phones with Android 6.0 or higher. If the app wants to connect to Bluetooth, it must request the location permission. Please refer to this page (https://developer.android.com/about/versions/marsh...
2. Google recently had a rule that requires all apps on google play to support android 8.0. If not, we will not be able to upload apps to google play. You can refer to the web page (Https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html). Therefore, the newest app must support 8.0 system, and it must also support 6.0. In other words, the app wants Bluetooth to connect properly, it needs to request the location permissions.
3.If you are our old user, we hope you know that the previous version of the PICOOC app, the highest supported is the android5.0 system. This means that even if your phone system is higher than 5.0, our app will run the app in android5.0 mode. So, you won't see a request for explicit location permissions.

I hope you can understand us, we don't want to get location permissions, just to meet google's requirements. In addition, I promise you that although my app insists on location permissions, it is just for Bluetooth to connect properly, we have not collected any location information such as your latitude and longitude.

I am very sorry, but I hope you can accept our explanation. If you have any questions, please contact us again!
  • Вопрос задан
  • 79 просмотров
Пригласить эксперта
Ответы на вопрос 1
thelongrunsmoke
@thelongrunsmoke
Программист
На самом деле, когда вы ищете устройства Bluetooth или WiFi, вы раскрываете своё местоположение. На этот факт, теперь указывают явно. Однако, главная проблема - Bluetooth Low Energy, который использует местоположение для поиска ближайших устройств.
Поставьте себе старую версию приложения, если вас это волнует.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы
Blogman Оренбург
от 20 000 до 110 000 руб.
Frogogo Москва
от 100 000 руб.
BTlabs Москва
от 60 000 руб.
17 янв. 2019, в 05:58
700 руб./в час
16 янв. 2019, в 22:45
1000 руб./за проект