alex_shevch
@alex_shevch
PM, Frontend Developer

Как установить mysql ubuntu 18?

Всем привет!
Помогите пожалуйста поднять mysql.

Набираю:
sudo apt install mysql-server

Получаю:

dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.7; however:
  Package mysql-server-5.7 is not installed.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)


Говорит установи 5.7, ну окей - sudo apt install mysql-server-5.7

Получаю:

mysql-server-5.7 is already the newest version (5.7.24-0ubuntu0.18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
2 not fully installed or removed.
Need to get 0 B/3 193 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.7; however:
  Package mysql-server-5.7 is not installed.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Вопрос задан
  • 498 просмотров
Решения вопроса 2
sudo apt-get autoremove
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
bestking5236
@bestking5236
постоянно устраиваю необычные проделки
apt install mysql-server-5.7
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы