@vanes815

Из-за чего npm ERR! code ELIFECYCLE?

Здравствуйте. Linux Mint 18 Cinnamon. При установке gulp вылетает ошибка ELIFECYCLE.
Устанавливал, как здесь ссылка
Вот лог:
spoiler
22832 warn optimizedhtml@3.0.0 No repository field.
22833 warn optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
22834 warn notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
22835 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS: darwin
22835 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch: any
22835 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS: linux
22835 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64
22836 verbose stack Error: node-sass@4.11.0 postinstall: `node scripts/build.js`
22836 verbose stack Exit status 1
22836 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:301:16)
22836 verbose stack at EventEmitter.emit (events.js:188:13)
22836 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
22836 verbose stack at ChildProcess.emit (events.js:188:13)
22836 verbose stack at maybeClose (internal/child_process.js:978:16)
22836 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:265:5)
22837 verbose pkgid node-sass@4.11.0
22838 verbose cwd /home/moops/work/DV7/_html
22839 verbose Linux 4.15.0-20-generic
22840 verbose argv "/usr/bin/node" "/usr/bin/npm" "i"
22841 verbose node v11.6.0
22842 verbose npm v6.5.0-next.0
22843 error code ELIFECYCLE
22844 error errno 1
22845 error node-sass@4.11.0 postinstall: `node scripts/build.js`
22845 error Exit status 1
22846 error Failed at the node-sass@4.11.0 postinstall script.
22846 error This is probably not a problem with npm. There is likely additional logging output above.


Подскажите пожалуйста в чем проблема.
  • Вопрос задан
  • 113 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы