@the_scs
Погромист-самоучка

Как преобразовать правила iptables в правила для Mikrotik?

Добрый день.
Прошу помощи, есть правила под iptables, но как их запихнуть в микротик, хоть убей, не пойму.
Пробовал и так, и сяк... опустились руки уже.
Буду очень признателен за любую подсказку.
iptables -t nat -A PREROUTING -p tcp -d 10.0.0.0/8 -j REDIRECT --to-port 9040
iptables -t nat -A OUTPUT -p tcp -d 10.0.0.0/8 -j REDIRECT --to-port 9040
#### Переадресация по домену ".onion" ####<code></code>
iptables -t nat -A PREROUTING -p udp --dport 53 -m string \ --hex-string "|056f6e696f6e00|" --algo bm -j REDIRECT --to-ports 5300
iptables -t nat -A OUTPUT -p udp --dport 53 -m string \ --hex-string "|056f6e696f6e00|" --algo bm -j REDIRECT --to-ports 5300


микротик
/ip firewall nat
add action=redirect chain=dstnat comment="TOR redir. DNS" disabled=no \
    dst-port=53 layer7-protocol=Onion port=53 protocol=udp to-ports=5300
add action=redirect chain=dstnat comment="TOR Connections redir." disabled=no \
    dst-address=10.0.0.0/8 protocol=tcp to-ports=9040
add action=masquerade chain=srcnat comment="Def. Masq" disabled=no \
    out-interface=ether2-wan
  • Вопрос задан
  • 367 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Enapter Санкт-Петербург
от 120 000 до 180 000 руб.
Leningrad Media Санкт-Петербург
от 60 000 до 80 000 руб.
Studio Evolution Тверь
от 60 000 до 150 000 руб.
25 июн. 2019, в 00:24
15000 руб./за проект
24 июн. 2019, в 23:27
8000 руб./за проект