CrewCut
@CrewCut
Коплю силы на переезд в тропики

Как в Excel очистить значения строк-дублей в рамках одинаковых значений колонки?

Есть выгрузка данных по заказам, где первая колонка - номер заказа. Из-за того, что в одном заказе несколько товаров, то для каждого заказа есть несколько строк. Проблема в том, что затраты на весь заказ (комплектация, себестоимость доставки и т.п.) выводятся в каждой строке. Получается, что в рамках заказа дублируются расходы.

Задача: в рамках строк, с повторяющимся значением первой колонки, удалить значения всех строк во всех колонках, кроме первой такой строки и первой колонки всех строк. Какими функциями этого можно достичь? Никак не разберусь.

На примере: вверху стартовая таблица, внизу требуемый результат.
5c3873eb9a60f191192837.png
  • Вопрос задан
  • 51 просмотр
Решения вопроса 1
CrewCut
@CrewCut Автор вопроса
Коплю силы на переезд в тропики
Как обычно - стоило спросить и решение нашлось.

1. Пронумеруем уникальные номера по нужной мне колонке функцией =ЕСЛИ(СЧЁТЕСЛИ(B$1:B2;B2)=1;МАКС(A$1:A1)+1;"") - см Способ 3 тут https://www.planetaexcel.ru/techniques/14/103/
2. Для каждой колонки, которую надо проверить (удалить/оставить) создаем рядом соседнюю, в которой простой формулой ЕСЛИ проверяем - если нет номера, значит не уникальная и значение выводить не надо.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@MAGistr_MTM
Учусь программировать
=IF(A2<>A1;D2;"")
Логика какая, нужно отсортировать по номеру заказа, и потом проверять в столбце собестоимости, по столбцу номеру заказа, над ним(предедущий) имеет тот же номер. Если тот же, значить не должно быть числа, если другой - значить заказ новый.
Можно проверять через индекс и текущую строку, но тал немножко сложнее и длинее.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через TM ID
Похожие вопросы
ВИЗАВИ Консалт Москва
от 90 000 до 100 000 руб.
Группа АБСОЛЮТ Москва
от 120 000 до 150 000 руб.
от 150 000 до 200 000 руб.
22 янв. 2019, в 17:47
300 руб./за проект
22 янв. 2019, в 17:36
600 руб./за проект
22 янв. 2019, в 17:30
100 руб./за 1000 зн.