@EvgeniiR
https://github.com/EvgeniiR

Ломается фронт на vue при попытке обновить laravel-mix до версии без уязвимости?

Жил себе без проблем с laravel-mix и фронтом на vue.js, недавно Гитхаб заявил что у меня в приложении уязвимость в Laravel-mix, о чем также говорит npm.

npm audit fix не смог ничего сделать.
npm audit fix --force или ручное обновление laravel-mix ( npm install --save-dev laravel-mix@4.0.14 ) при последующем npm run dev выдаёт следующее:
spoiler
npm run dev

> ws-chat@1.0.0 dev /var/www/ws-chat
> NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js

        Additional dependencies must be installed. This will only take a moment.
 
        Running: yarn add vue-template-compiler --dev --production=false
 
warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
        Okay, done. The following packages have been installed and saved to your package.json dependencies list:
 
        - vue-template-compiler
 
        Additional dependencies must be installed. This will only take a moment.
 
        Running: yarn add sass-loader@7.* sass resolve-url-loader@2.3.1 --dev --production=false
 
warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
warning " > sass-loader@7.1.0" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
        Okay, done. The following packages have been installed and saved to your package.json dependencies list:
 
        - sass-loader@7.*
 
        - sass
 
        - resolve-url-loader@2.3.1
 
        Finished. Please run Mix again.



При последующем вызове:
spoiler

npm run dev

> ws-chat@1.0.0 dev /var/www/ws-chat
> NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js

98% after emitting SizeLimitsPlugin

DONE Compiled successfully in 14837ms 9:04:48 PM

Asset Size Chunks Chunk Names
/public/js/app.js 817 KiB /public/js/app [emitted] /public/js/app
public/css/app.css 172 KiB /public/js/app [emitted] /public/js/app


После этого в консоли браузера вижу ошибку:
<spoiler title="">[Vue warn]: Failed to mount component: template or render function not defined.

found in

---> <Chatbox>
       <Root></spoiler>


Chatbox это мой компонент который до обновления работал корректно.

После ещё одного npm install
при попытке npm run dev получаем:
Vue packages version mismatch:

- vue@2.5.17
- vue-template-compiler@2.5.22


У кого-то получилось пофиксить данную проблему?
  • Вопрос задан
  • 326 просмотров
Пригласить эксперта
Ответы на вопрос 1
@grinat
- vue@2.5.17
- vue-template-compiler@2.5.22

Насколько помню их версии должны совпадать, пропиши в packahe.json
vue: ~2.5.17
vue-template-compiler: ~2.5.17
либо
vue: ~2.5.22
vue-template-compiler: ~2.5.22
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы