DopustimVladimir
@DopustimVladimir
Веб-ориентированный программист

Как локально поставить Python 3.7.0 на shared-хостинге?

Всем привет! Пытаюсь поставить Python 3.7.0 на shared-хостинг. Правда, есть кое-какие неприятности. Окей, иду за libffi и запускаю автоген. Но не тут то было и теперь ругается Perl на настройки локали. Хм, да вроде бы все в порядке там. Такая вот перловка:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ru:en",
	LC_ALL = (unset),
	LC_COLLATE = "ru_RU.UTF-8",
	LC_CTYPE = "UTF-8",
	LC_TIME = "en_US.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal -I m4
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ru:en",
	LC_ALL = (unset),
	LC_COLLATE = "ru_RU.UTF-8",
	LC_CTYPE = "UTF-8",
	LC_TIME = "en_US.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ru:en",
	LC_ALL = (unset),
	LC_COLLATE = "ru_RU.UTF-8",
	LC_CTYPE = "UTF-8",
	LC_TIME = "en_US.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
configure.ac:3: error: Autoconf version 2.68 or higher is required
configure.ac:3: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
aclocal: autom4te failed with exit status: 63
autoreconf: aclocal failed with exit status: 63
  • Вопрос задан
  • 164 просмотра
Решения вопроса 1
@ky0
Миллиардер, филантроп, патологический лгун
На вашем шареде пакеты не той версии:
Autoconf version 2.68 or higher is required


Ну и вообще - обычно сборка чего-либо своего на шареде не предусмотрена.
Ответ написан
Пригласить эксперта
Ответы на вопрос 3
netpastor
@netpastor
Python developer
Попробуй установить pyenv
https://github.com/pyenv/pyenv
Ответ написан
opium
@opium
Просто люблю качественно работать
На шаредах обычно не дают ничего ставить так что увы вам светит вдс
Ответ написан
CityCat4
@CityCat4
Кошки не похожи на людей, кошки - это кошки!
Никак.

Хостинг - это "жрите, что налили". Чтобы самому решать, какие версии чего ставить в систему - нужен VDS. У клиентов хостинга просто прав нет на запись в системные каталоги. Да, можно сдублировать весь autotools, и все необходимые либы - но тогда Вам придется провернуть работу, примерно сравнимую с работой по обслуживанию VDS - а тогда какая нафиг Вам разница?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы