@adil16

Установка gulp в webstorm, как установить на windows?

Здравствуйте. Решил начать обучение по sass, создал в вебшторм package.json, далее хотел установить gulp, ввел в терминале команду npm i gulp --save dev, выдало следующую ошибку:
npm ERR! code EBADPLATFORM
npm ERR! notsup Unsupported platform for inotify@1.4.6: wanted {"os":"linux","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm ERR! notsup Valid OS:    linux
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   win32
npm ERR! notsup Actual Arch: x64
  • Вопрос задан
  • 50 просмотров
Пригласить эксперта
Ответы на вопрос 1
sfi0zy
@sfi0zy
UI developer. Верстаю неверстаемое.
Вы опечатались, между "save" и "dev" должен быть дефис: npm i gulp --save-dev.

Ваша же (некорректная в данной ситуации) команда говорит npm установить пакет dev, который зависит от пакета inotify, который предназначен только для linux, и, разумеется, под windows возникает ошибка "эта платформа не поддерживается".
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы