@danilr

Плагин слайдер для Vue выдает ошибку, как можно починить?

Использую вот этот плагин слайдер https://www.npmjs.com/package/vue-slider-component
<v-slider
@drag-end="setPriceFilter"
v-model="rangeSum"
:enable-cross="false"
:min="allRcMinPrice"
:max="allRcMaxPrice"
:interval="100000"
></v-slider>

rangeSum: {
			get() {
				let rangeSum = [this.minSum, this.maxSum];
				return rangeSum;
			},
			set(value) {
        this.minSum = value[0];
				this.maxSum = value[1];
			}
		},

Задача в том, что мне нужно чтобы при нажатии на определенную кнопку граница ( минимальное значение) менялось.
Это делаю так:
if(this.minSum < this.newMinPrice){ // этим условием пытался исправить эту ошибку
          this.minSum = this.newMinPrice //устанавливаю min value
          this.setNewAllMinPrice(this.newMinPrice) // устанавливаю min границу( через Vuex)
        }
        else{
          this.minSum = this.newMinPrice
          this.setNewAllMinPrice(this.newMinPrice)
        }

Это работает, но постоянно выдает ошибку при каждом использовании.
Как можно избавиться от ошибки?
5cd1536987077258957794.png
  • Вопрос задан
  • 66 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы