@RabIN

Почему такая ошибка «Your requirements could not be resolved to an installable set of packages.»?

Добрый день, помогите, пожалуйста...
что от меня хочет композер?
{
  "name": "zendframework/skeleton-application",
  "description": "Skeleton Application for Zend Framework zend-mvc applications",
  "type": "project",
  "license": "BSD-3-Clause",
  "keywords": [
    "framework",
    "mvc",
    "zf"
  ],
  "homepage": "http://framework.zend.com/",
  "minimum-stability": "dev",
  "prefer-stable": true,
  "require": {
    "php": "^5.6 || ^7.0",
    "zendframework/zend-component-installer": "^1.0 || ^0.7 || ^1.0.0-dev@dev",
    "zendframework/zend-mvc": "^3.0.1",
    "zfcampus/zf-development-mode": "^3.0",
    "zendframework/zend-form": "^2.14",
    "zendframework/zend-db": "^2.10",
    "zendframework/zend-i18n": "^2.9",
    "zendframework/zend-hydrator": "^2.4"
  },
  "autoload": {
    "psr-4": {
      "Application\\": "module/Application/src/",
      "Album\\": "module/Album/src/"
    }
  },
  "autoload-dev": {
    "psr-4": {
      "ApplicationTest\\": "module/Application/test/"
    }
  },
  "extra": [],
  "scripts": {
    "cs-check": "phpcs",
    "cs-fix": "phpcbf",
    "development-disable": "zf-development-mode disable",
    "development-enable": "zf-development-mode enable",
    "development-status": "zf-development-mode status",
    "post-create-project-cmd": [
      "@development-enable"
    ],
    "serve": "php -S 0.0.0.0:8080 -t public public/index.php",
    "test": "phpunit"
  }
}


Ошибка такая при попытке установить доктрину
docker-compose run composer require doctrine/doctrine-orm-module
Using version ^2.1 for doctrine/doctrine-orm-module
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package zendframework/zend-hydrator (locked at 3.0.2, required as ^2.4) is satisfiable by zendframework/zend-hydrator[3.0.2] but these conflict with your requirements or minimum-stability.


Installation failed, reverting ./composer.json to its original content.
verahope@verahope-MS-7B46:~/Документы/zendframework$ docker-compose run composer require doctrine/doctrine-orm-module
Using version ^2.1 for doctrine/doctrine-orm-module
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install doctrine/doctrine-orm-module 2.1.4
    - Conclusion: don't install doctrine/doctrine-orm-module 2.1.3
    - Conclusion: don't install doctrine/doctrine-orm-module 2.1.2
    - Conclusion: don't install doctrine/doctrine-orm-module 2.1.1
    - Conclusion: remove zendframework/zend-hydrator 3.0.2
    - Installation request for doctrine/doctrine-orm-module ^2.1 -> satisfiable by doctrine/doctrine-orm-module[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4].
    - Conclusion: don't install zendframework/zend-hydrator 3.0.2
    - doctrine/doctrine-orm-module 2.1.0 requires zendframework/zend-hydrator ^1.1 || ^2.2.1 -> satisfiable by zendframework/zend-hydrator[1.1.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.x-dev].
    - Can only install one of: zendframework/zend-hydrator[1.1.0, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.2.1, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.2.2, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.2.3, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.3.0, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.3.1, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.4.0, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.4.1, 3.0.2].
    - Can only install one of: zendframework/zend-hydrator[2.4.x-dev, 3.0.2].
    - Installation request for zendframework/zend-hydrator (locked at 3.0.2) -> satisfiable by zendframework/zend-hydrator[3.0.2].


Installation failed, reverting ./composer.json to its original content.
  • Вопрос задан
  • 118 просмотров
Решения вопроса 1
HeadOnFire
@HeadOnFire
PHP, Laravel & WordPress Evangelist
Конфликт версий зависимостей, между собой. Удалите composer.lock и установите (или укажите вручную в composer.json) совместимые версии согласно рекомендациям (весь лог не читал и не вникал, но по ходу doctrine/doctrine-orm-module просит более старую версию zendframework/zend-hydrator).
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы