@Yojj

NodeJS 9.2: parcel + sqlite3 — как решить ошибку?

Возникла необходимость в html страничку выводить данные из бд sqlite
на NodeJS 9.2 использую "parcel": "^1.12.3", "sqlite": "^3.0.3"

Запускаю npm run build, затем parcel index.html, но возникает ошибка
Server running at http://localhost:1234 
...../MyProj/node_modules/node-pre-gyp/lib/node-pre-gyp.js:136:48: Cannot statica
lly evaluate fs argument
  134 |   var dir = this.opts.directory;
  135 |   if (dir == null) dir = process.cwd();
> 136 |   var package_json = JSON.parse(fs.readFileSync(path.join(dir,'package.json')));
      |                                                ^
  137 | 
  138 |   this.todo = napi.expand_commands (package_json, this.opts, commands);
  139 | 
✨  Built in 9.18s.


Очевидный ответ не гуглится. Возможно ли решить без уменьшения версии Ноды?
или возможно есть альтернативный модуль для sqlite?
спасибо
  • Вопрос задан
  • 51 просмотр
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы