byte916
@byte916

Как выявить причину бесконечной загрузки страницы?

Windows 8.1, IIS 8.5. Ноутбук, долгое время использовался как главная машина для разработки, теперь стал "вариантом для отпуска", беру в поездки и раньше всё работало, описываемой проблемы не было.

Проблема следующая: при открытии localhost в браузере идёт бесконечная загрузка. Браузер пишет "Ожидание ответа localhost" и ничего не происходит, ни через минуту, ни через десять, ни через другой промежуток. Ошибок не выдаёт.

Пробовал запрашивать существующие и несуществующие страницы - так же вечная загрузка

Пробовал telnet localhost 80, далее GET что угодно - ничего не выдаёт, пустой экран, ожидание ответа. Если отправить не GET а невалидный запрос, то выдаёт ответ вида

spoiler
HTTP/1.1 400 Bad Request
Content-Type: text/html; charset=us-ascii
Server: Microsoft-HTTPAPI/2.0
Date: Thu, 11 Jul 2019 02:39:12 GMT
Connection: close
Content-Length: 326

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>Bad Request</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD>
<BODY><h2>Bad Request - Invalid Verb</h2>
<hr><p>HTTP Error 400. The request verb is invalid.</p>
</BODY></HTML>


Пробовал: перезагрузку, переустановку IIS, установку всех компонентов которые есть в IIS - ничего не помогло.

Логи включены, но папка с логами пустая. Нашёл логи в папке C:\Windows\System32\Logfiles\HTTPERR
Но содержимое странное - почти все мои запросы отсутствуют
spoiler
#Software: Microsoft HTTP API 2.0
#Version: 1.0
#Date: 2019-07-11 02:14:59
#Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
2019-07-11 02:14:59 ::1%0 50292 ::1%0 80 - - - - - Timer_ConnectionIdle -
2019-07-11 02:17:41 ::1%0 50291 ::1%0 80 HTTP/1.1 GET / - 1 Connection_Abandoned_By_ReqQueue DefaultAppPool
2019-07-11 02:17:41 ::1%0 50303 ::1%0 80 HTTP/1.1 GET / - 1 Connection_Abandoned_By_ReqQueue DefaultAppPool
2019-07-11 02:17:41 ::1%0 50511 ::1%0 80 HTTP/1.1 GET / - 1 Connection_Abandoned_By_ReqQueue DefaultAppPool
2019-07-11 02:17:41 ::1%0 50513 ::1%0 80 HTTP/1.1 GET / 503 1 N/A DefaultAppPool
2019-07-11 02:17:41 ::1%0 50512 ::1%0 80 HTTP/1.1 GET / 503 1 N/A DefaultAppPool
2019-07-11 02:17:41 ::1%0 50514 ::1%0 80 HTTP/1.1 GET /favicon.ico 503 1 N/A DefaultAppPool
2019-07-11 02:17:41 ::1%0 50515 ::1%0 80 HTTP/1.1 GET /favicon.ico 503 1 N/A DefaultAppPool
2019-07-11 02:30:49 ::1%0 50665 ::1%0 80 - - - - - Timer_ConnectionIdle -
2019-07-11 02:38:34 ::1%0 50865 ::1%0 80 - - - - - Timer_ConnectionIdle -
2019-07-11 02:39:12 ::1%0 50875 ::1%0 80 - - - 400 - Verb -
2019-07-11 02:50:30 ::1%0 50986 ::1%0 80 - - - - - Timer_ConnectionIdle -


Обратил внимание, что при перезапуске сервиса iisreset /restart в логах появляются записи о том что текущие открытые соединения (те страницы, которые я пытаюсь открыть и которые не открываются) дропнуты.
2019-07-11 02:59:40 ::1%0 50965 ::1%0 80 HTTP/1.1 GET / - 1 Connection_Dropped DefaultAppPool


Как диагностировать проблему и искать причину?
  • Вопрос задан
  • 21 просмотр
Пригласить эксперта
Ответы на вопрос 1
@rPman
антивирус?
возможно странные настройки на фаерволе?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы