Почему не работает RDP к VirtualBox?

Переношу виртуальную машину с MacOS на Debian 9 без GUI. Установил на сервере VitrualBox и расширение для работы с RDP (Oracle_VM_VirtualBox_Extension_Pack-6.0.10-132072.vbox-extpack ).

Импортировал .ova-файл, запуск машины производится:
root:~/ # vboxmanage startvm "Debian 10" --type headless                                         [14:46:39]
Waiting for VM "Debian 10" to power on...
VM "Debian 10" has been successfully started.


Но при подключении к серверу с iMac через RDP (Parallels Client), вижу просто черный экран с курсором. Если ввести некорректные логин-пароль, то также открывается черный экран с курсором. Т.е. вход в Debian в действительности не производится.

Тем не менее, при запуске # VBoxManage showvminfo 'Debian 10' вижу информацию о своем подключении:

VRDE Connection:             active
Clients so far:              2
Start time:                  2019/07/26 11:50:02 UTC
Sent:                        27810Bytes
Average speed:               615B/s
Sent total:                  27810Bytes
Received:                    18849Bytes
Speed:                       417B/s
Received total:              18849Bytes
User name:                   vsokolov
Domain:
Client name:                 Vitaly’s iMac
Client IP:                   192.168.1.80
Client version:              3790
Encryption:                  RDP4


Вот вывод полностью:
Name:                        Debian 10
Groups:                      /
Guest OS:                    Debian (64-bit)
UUID:                        4812351a-f969-4484-a0bb-37dc22a920a2
Config file:                 /root/VirtualBox VMs/Debian 10/Debian 10.vbox
Snapshot folder:             /root/VirtualBox VMs/Debian 10/Snapshots
Log folder:                  /root/VirtualBox VMs/Debian 10/Logs
Hardware UUID:               4812351a-f969-4484-a0bb-37dc22a920a2
Memory size                  2048MB
Page Fusion:                 disabled
VRAM size:                   128MB
CPU exec cap:                100%
HPET:                        disabled
CPUProfile:                  host
Chipset:                     piix3
Firmware:                    BIOS
Number of CPUs:              1
PAE:                         disabled
Long Mode:                   enabled
Triple Fault Reset:          disabled
APIC:                        enabled
X2APIC:                      enabled
Nested VT-x/AMD-V:           disabled
CPUID Portability Level:     0
CPUID overrides:             None
Boot menu mode:              message and menu
Boot Device 1:               Floppy
Boot Device 2:               DVD
Boot Device 3:               HardDisk
Boot Device 4:               Not Assigned
ACPI:                        enabled
IOAPIC:                      enabled
BIOS APIC mode:              APIC
Time offset:                 0ms
RTC:                         UTC
Hardw. virt.ext:             enabled
Nested Paging:               enabled
Large Pages:                 enabled
VT-x VPID:                   enabled
VT-x unr. exec.:             enabled
Paravirt. Provider:          Default
Effective Paravirt. Prov.:   KVM
State:                       running (since 2019-07-26T11:47:06.263000000)
Monitor count:               1
3D Acceleration:             disabled
2D Video Acceleration:       disabled
Teleporter Enabled:          disabled
Teleporter Port:             0
Teleporter Address:
Teleporter Password:
Tracing Enabled:             disabled
Allow Tracing to Access VM:  disabled
Tracing Configuration:
Autostart Enabled:           disabled
Autostart Delay:             0
Default Frontend:
Storage Controller Name (0):            IDE
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
Storage Controller Name (1):            SATA
Storage Controller Type (1):            IntelAhci
Storage Controller Instance Number (1): 0
Storage Controller Max Port Count (1):  30
Storage Controller Port Count (1):      1
Storage Controller Bootable (1):        on
IDE (1, 0): Empty
SATA (0, 0): /root/VirtualBox VMs/Debian 10/Debian 10-disk001.vmdk (UUID: 68e0d246-b106-4c32-a636-6c78ccb77c58)
NIC 1:                       MAC: 0800########, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 1 Settings:  MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)
NIC 2:                       disabled
NIC 3:                       disabled
NIC 4:                       disabled
NIC 5:                       disabled
NIC 6:                       disabled
NIC 7:                       disabled
NIC 8:                       disabled
Pointing Device:             USB Tablet
Keyboard Device:             PS/2 Keyboard
UART 1:                      disabled
UART 2:                      disabled
UART 3:                      disabled
UART 4:                      disabled
LPT 1:                       disabled
LPT 2:                       disabled
Audio:                       enabled (Driver: ALSA, Controller: AC97, Codec: AD1980)
Audio playback:              enabled
Audio capture:               disabled
Clipboard Mode:              Bidirectional
Drag and drop Mode:          disabled
Session name:                headless
Video mode:                  720x400x0 at 0,0 enabled
VRDE:                        enabled (Address 0.0.0.0, Ports 3389, MultiConn: off, ReuseSingleConn: off, Authentication type: null)
VRDE port:                   3389
Video redirection:           disabled
VRDE property               : TCP/Ports  = "3389"
VRDE property               : TCP/Address = <not set>
VRDE property               : VideoChannel/Enabled = <not set>
VRDE property               : VideoChannel/Quality = <not set>
VRDE property               : VideoChannel/DownscaleProtection = <not set>
VRDE property               : Client/DisableDisplay = <not set>
VRDE property               : Client/DisableInput = <not set>
VRDE property               : Client/DisableAudio = <not set>
VRDE property               : Client/DisableUSB = <not set>
VRDE property               : Client/DisableClipboard = <not set>
VRDE property               : Client/DisableUpstreamAudio = <not set>
VRDE property               : Client/DisableRDPDR = <not set>
VRDE property               : H3DRedirect/Enabled = <not set>
VRDE property               : Security/Method = <not set>
VRDE property               : Security/ServerCertificate = <not set>
VRDE property               : Security/ServerPrivateKey = <not set>
VRDE property               : Security/CACertificate = <not set>
VRDE property               : Audio/RateCorrectionMode = <not set>
VRDE property               : Audio/LogPath = <not set>
OHCI USB:                    enabled
EHCI USB:                    disabled
xHCI USB:                    disabled

USB Device Filters:

<none>

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>

Bandwidth groups:  <none>

Shared folders:<none>

VRDE Connection:             active
Clients so far:              2
Start time:                  2019/07/26 11:50:02 UTC
Sent:                        27810Bytes
Average speed:               615B/s
Sent total:                  27810Bytes
Received:                    18849Bytes
Speed:                       417B/s
Received total:              18849Bytes
User name:                   vsokolov
Domain:
Client name:                 Vitaly’s iMac
Client IP:                   192.168.1.80
Client version:              3790
Encryption:                  RDP4

Capturing:                   not active
Capture audio:               not active
Capture screens:             0
Capture file:                /root/VirtualBox VMs/Debian 10/Debian 10.webm
Capture dimensions:          1024x768
Capture rate:                512kbps
Capture FPS:                 25kbps
Capture options:

Guest:

Configured memory balloon size: 0MB
OS type:                     Debian_64
Additions run level:         0

Guest Facilities:

Facility "Seamless Mode": not active (last update: 2019/07/26 11:47:06 UTC)


Подскажите, куда копать? Проблема на клиенте или на сервере?
  • Вопрос задан
  • 125 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы