IgorPI
@IgorPI

Как удалить пакет если он не удаляется?

Как удалить этот чёртов пакет ISPmanager?
Уже реально достал, он находится в списке, мне нужно его переустановить.

Передо мной задача:

Удалить остатки сломанных пакетов.
Заново установить. (с установкой всё в порядке)

Уже пробовал всеми способами.
Чёртов китайский сервер не хочет его удалять, мол где-то он в процессах, но реально, его негде в процессах нет.

Самое забавное, что у жителей поднебесной нет возможности переустановить систему, можно только отказаться от услуги и заново купить, что не входит в планы.

Вот этот шлак, хочу удалить
root@ruintouch:/tmp# apt list | grep ispmanager

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

ispmanager-lite/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-lite-common/unstable,now 5.210.0-1-ubuntu18 amd64 [installed]
ispmanager-lite-dev/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-pkg-afterlogic/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-awstats/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-bind/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-clamav-exim/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-clamav-postfix/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-clamav-sendmail/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-docker/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-dovecot/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-exim/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-greylisting-exim/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-greylisting-postfix/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-greylisting-sendmail/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-httpd/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-httpd-itk/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-logrotate/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-myadmin/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-mysql/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-nginx/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-nginx-business/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-opendkim-exim/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-opendkim-postfix/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-opendkim-sendmail/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-pdns/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-pgadmin/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-php/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-phpext-ioncube/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-phpfpm/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-postfix/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-postgresql/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-proftpd/unstable,unstable,now 5.210.0-1-ubuntu18 all [residual-config]
ispmanager-pkg-psacct/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-pureftpd/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-quota/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-roundcube/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-sendmail/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-sieve/unstable,unstable,now 5.210.0-1-ubuntu18 all [installed]
ispmanager-pkg-spamassassin-exim/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-spamassassin-postfix/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-spamassassin-sendmail/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-pkg-webalizer/unstable,unstable 5.210.0-1-ubuntu18 all
ispmanager-plugin-cloudflare/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-ddosguard/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-dnssecinfo/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-kernelcare/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-letsencrypt/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-oneclickssl/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-revisium/unstable,now 5.210.0-1-ubuntu18 amd64 [installed]
ispmanager-plugin-siteprobuilder/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-softaculous/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-virusdie/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugin-virusdie-pro/unstable 5.210.0-1-ubuntu18 amd64
ispmanager-plugins/unstable,now 5.210.0-1-ubuntu18 amd64 [installed,automatic]


apt remove ispmanager*

out

Errors were encountered while processing:
ispmanager-plugin-revisium
ispmanager-pkg-awstats
ispmanager-pkg-bind
ispmanager-pkg-sieve
ispmanager-pkg-roundcube
ispmanager-pkg-myadmin
ispmanager-pkg-logrotate
ispmanager-pkg-mysql
ispmanager-lite-common
ispmanager-pkg-dovecot
ispmanager-pkg-exim
ispmanager-pkg-php
ispmanager-pkg-httpd-itk
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ruintouch:/tmp#
  • Вопрос задан
  • 50 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы