@artemdrake2013
21 год

Как в excel 2007 транспонировать несколько столбцов в одну строку?

На скриншоте есть два столбца и строка, в которую должны конкретным образом транспонироваться столбцы. Строка с транспонированными столбцами может быть на листе где угодно. Как это можно сделать?
5d67ab02c0357879998522.png
  • Вопрос задан
  • 43 просмотра
Пригласить эксперта
Ответы на вопрос 2
Volounteer
@Volounteer
Формула:

=ИНДЕКС($A$1:$B$11;ОКРУГЛ(СТОЛБЕЦ(A1)/2;0);ОСТАТ(СТОЛБЕЦ(A1)-1;2)+1)
Ответ написан
@ClearAirTurbulence
Судя по скриншоту, сначала нужно оба столбца слить в один последовательно, затем отсортировать, а затем уже транспонировать.
Можно сделать руками описанным Алекс Кузнец образом.

Либо пополам - сделать столбец, который бы объединял столбцы с помощью формул\vba
https://www.extendoffice.com/documents/excel/4233-...
А его уже руками сортировать \ транспонировать куда надо

А можно все делать с помощью vba
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы