@nicedayz

Composer update. Rejected by your constraint. Как исправить?

На проекте yii2 перестала работать авторизация соцсетей, понадобилось обновить yiisoft/yii2-authclient

composer update "yiisoft/yii2-authclient" --ignore-platform-reqs --prefer-dist --no-dev
Получаю ошибки
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
                                                                                                                                                                                
  Problem 1                                                                                                                                                                     
    - The requested package phpdocumentor/reflection-common (locked at 1.0.x-dev) exists as phpdocumentor/reflection-common[0.1, 0.2, 0.3, 1.0, 1.0.1, 2.0.0, 2.0.0-alpha1, 2.0.
0-alpha2, 2.0.0-alpha3, 2.0.0-beta1, dev-master, 2.x-dev] but these are rejected by your constraint.                                                                            
  Problem 2                                                                                                                                                                     
    - The requested package phpunit/phpunit (locked at 5.7.x-dev) exists as phpunit/phpunit[3.7.0, 3.7.1, 3.7.10, 3.7.11, 3.7.12, 3.7.13, 3.7.14, 3.7.15, 3.7.16, 3.7.17, 3.7.18
, 3.7.19, 3.7.2, 3.7.20, 3.7.21, 3.7.22, 3.7.23, 3.7.24, 3.7.25, 3.7.26, 3.7.27, 3.7.28, 3.7.29, 3.7.3, 3.7.30, 3.7.31, 3.7.32, 3.7.33, 3.7.34, 3.7.35, 3.7.36, 3.7.37, 3.7.38, 
3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.7.8, 3.7.9, 4.0.0, 4.0.1, 4.0.10, 4.0.11, 4.0.12, 4.0.13, 4.0.14, 4.0.15, 4.0.16, 4.0.17, 4.0.18, 4.0.19, 4.0.2, 4.0.20, 4.0.3, 4.0.4, 4.0.5, 4.0.
6, 4.0.7, 4.0.8, 4.0.9, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.2.6, 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.4.0, 4.4.1
, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.5.0, 4.5.1, 4.6.0, 4.6.1, 4.6.10, 4.6.2, 4.6.3, 4.6.4, 4.6.5, 4.6.6, 4.6.7, 4.6.8, 4.6.9, 4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 4.7.6, 4.7.7
, 4.8.0, 4.8.1, 4.8.10, 4.8.11, 4.8.12, 4.8.13, 4.8.14, 4.8.15, 4.8.16, 4.8.17, 4.8.18, 4.8.19, 4.8.2, 4.8.20, 4.8.21, 4.8.22, 4.8.23, 4.8.24, 4.8.25, 4.8.26, 4.8.27, 4.8.28, 4
.8.29, 4.8.3, 4.8.30, 4.8.31, 4.8.32, 4.8.33, 4.8.34, 4.8.35, 4.8.36, 4.8.4, 4.8.5, 4.8.6, 4.8.7, 4.8.8, 4.8.9, 5.0.0, 5.0.1, 5.0.10, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 
5.0.8, 5.0.9, 5.1.0, 5.1.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.1.7, 5.2.0, 5.2.1, 5.2.10, 5.2.11, 5.2.12, 5.2.2, 5.2.3, 5.2.4, 5.2.5, 5.2.6, 5.2.7, 5.2.8, 5.2.9, 5.3.0, 5.3.1
, 5.3.2, 5.3.3, 5.3.4, 5.3.5, 5.4.0, 5.4.1, 5.4.2, 5.4.3, 5.4.4, 5.4.5, 5.4.6, 5.4.7, 5.4.8, 5.5.0, 5.5.1, 5.5.2, 5.5.3, 5.5.4, 5.5.5, 5.5.6, 5.5.7, 5.6.0, 5.6.1, 5.6.2, 5.6.3,
 5.6.4, 5.6.5, 5.6.6, 5.6.7, 5.6.8, 5.7.0, 5.7.1, 5.7.10, 5.7.11, 5.7.12, 5.7.13, 5.7.14, 5.7.15, 5.7.16, 5.7.17, 5.7.18, 5.7.19, 5.7.2, 5.7.20, 5.7.21, 5.7.22, 5.7.23, 5.7.24,
 5.7.25, 5.7.26, 5.7.27, 5.7.3, 5.7.4, 5.7.5, 5.7.6, 5.7.7, 5.7.8, 5.7.9, 6.0.0, 6.0.1, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 
6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.1.4, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.2.4, 6.3.0, 6.3.1, 6.4.0, 6.4.1, 6.4.2, 6.4.3, 6.4.4, 6.5.0, 6.5.1, 6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5
.2, 6.5.3, 6.5.4, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.1.5, 7.2.0, 7.2.1, 7.2.2, 7.2.3, 7.2.4, 7.2.5, 7.2.6, 7.2.
7, 7.3.0, 7.3.1, 7.3.2, 7.3.3, 7.3.4, 7.3.5, 7.4.0, 7.4.1, 7.4.2, 7.4.3, 7.4.4, 7.4.5, 7.5.0, 7.5.1, 7.5.10, 7.5.11, 7.5.12, 7.5.13, 7.5.14, 7.5.15, 7.5.2, 7.5.3, 7.5.4, 7.5.5,
 7.5.6, 7.5.7, 7.5.8, 7.5.9, 7.5.x-dev, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.1, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.2.0, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2
.5, 8.3.0, 8.3.1, 8.3.2, 8.3.3, 8.3.4, 8.3.x-dev, dev-issue-3746/improve-developer-experience-of-global-wrapper-functions-for-assertions, dev-master, 8.4.x-dev, 6.5.x-dev] but 
these are rejected by your constraint.                                                                                                                                          
  Problem 3                                                                                                                                                                     
    - The requested package psr/log (locked at 1.0.x-dev) exists as psr/log[1.0.0, 1.0.1, 1.0.2, 1.1.0, dev-master, 1.1.x-dev] but these are rejected by your constraint.       
  Problem 4                                                                                                                                                                     
    - The requested package sebastian/version (locked at 2.0.x-dev) exists as sebastian/version[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 2.0.0, 2.0.1, dev-master, 3.0.x
-dev] but these are rejected by your constraint.                                                                                                                                
  Problem 5                                                                                                                                                                     
    - The requested package symfony/polyfill-mbstring (locked at 1.6.x-dev) exists as symfony/polyfill-mbstring[dev-master, 1.12.x-dev, v1.0.0, v1.0.1, v1.1.0, v1.1.1, v1.10.0,
 v1.11.0, v1.12.0, v1.2.0, v1.3.0, v1.3.1, v1.4.0, v1.5.0, v1.6.0, v1.7.0, v1.8.0, v1.9.0, 1.7.x-dev] but these are rejected by your constraint.


composer.json
{
  "name": "yiisoft/yii2-app-basic",
  "description": "Yii 2 Basic Project Template",
  "keywords": [
    "yii2",
    "framework",
    "basic",
    "project template"
  ],
  "homepage": "http://www.yiiframework.com/",
  "type": "project",
  "license": "BSD-3-Clause",
  "support": {
    "issues": "https://github.com/yiisoft/yii2/issues?state=open",
    "forum": "http://www.yiiframework.com/forum/",
    "wiki": "http://www.yiiframework.com/wiki/",
    "irc": "irc://irc.freenode.net/yii",
    "source": "https://github.com/yiisoft/yii2"
  },
  "minimum-stability": "dev",
  "require": {
    "php": ">=5.4.0",
    "yiisoft/yii2": "~2.0.13",
    "yiisoft/yii2-bootstrap": "~2.0.0",
    "yiisoft/yii2-swiftmailer": "~2.0.0",
    "kartik-v/yii2-widgets": "dev-master",
    "kartik-v/yii2-dialog": "@dev",
    "kartik-v/yii2-popover-x": "@dev",
    "kartik-v/yii2-editable": "@dev",
    "kartik-v/yii2-grid": "@dev",
    "kartik-v/yii2-tree-manager": "@dev",
    "2amigos/yii2-tinymce-widget": "~1.1",
    "costa-rico/yii2-images": "dev-master",
    "2amigos/yii2-usuario": "~1.1.0",
    "yiisoft/yii2-authclient": "@dev",
    "philippfrenzel/yii2fullcalendar": "*",
    "ruskid/yii2-csv-importer": "dev-master",
    "guzzlehttp/guzzle": "6.3.0",
    "johnrivs/wunderlist": "dev-master"
  },
  "require-dev": {
    "yiisoft/yii2-debug": "~2.0.0",
    "yiisoft/yii2-gii": "~2.0.0",
    "yiisoft/yii2-faker": "~2.0.0",
    "codeception/base": "^2.2.3",
    "codeception/verify": "~0.3.1",
    "codeception/specify": "~0.4.3"
  },
  "config": {
    "process-timeout": 1800,
    "discard-changes": true
  },
  "scripts": {
    "post-install-cmd": [
      "yii\\composer\\Installer::postInstall"
    ],
    "post-create-project-cmd": [
      "yii\\composer\\Installer::postCreateProject",
      "yii\\composer\\Installer::postInstall"
    ]
  },
  "extra": {
    "yii\\composer\\Installer::postCreateProject": {
      "setPermission": [
        {
          "runtime": "0777",
          "web/assets": "0777",
          "yii": "0755"
        }
      ]
    },
    "yii\\composer\\Installer::postInstall": {
      "generateCookieValidationKey": [
        "config/web.php"
      ]
    }
  },
  "repositories": [
    {
      "type": "composer",
      "url": "https://asset-packagist.org"
    }
  ]
}
  • Вопрос задан
  • 34 просмотра
Решения вопроса 1
Maksclub
@Maksclub
maksfedorov.ru
  • Верните к тому виду, как было.
  • Посмотрите веосии всех ваших зависимостей в composer.lock и аккуратно эти версии укажите строго в composer.json
  • Добейтесь того, чтобы все после этих действий работало ровно так, как все работает сейчас
  • Вернитесь к вопросу обновления пакета


Просто при апдейте вы тянете у нестабильных зависимостей свежий код, а у свежего уже их зависимости далеко ушли вперед
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы