На какой хук вешать условия перед установкой плагина WordPress?

Добрый день. На какой хук вешать условия проверки php или версии движка перед установкой плагина WordPress? Как правильно делать это?
  • Вопрос задан
  • 48 просмотров
Решения вопроса 1
deniscopro
@deniscopro Куратор тега WordPress
WordPress-разработчик, wpcute.ru
Добрый.

Можете указать в readme.txt следующие строки:
Requires at least: МИНИМАЛЬНАЯ_ВЕРСИЯ_WP
Requires PHP: МИНИМАЛЬНАЯ_ВЕРСИЯ_PHP

WordPress сделает проверку перед активацией плагина. А если плагин в оф. каталоге, то выдаст предупреждение в результатах поиска плагинов.

Ещё можно указать до какой версии WordPress тестировали плагин
Tested up to: ДО_КАКОЙ_ВЕРСИИ_WP_ТЕСТИРОВАЛИ
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы