@Analka

Ошибка при установке пакета composer?

из-за чего такая проблема при установке пакета?

composer-php7.3 require spatie/laravel-image-optimizer
Using version ^1.5 for spatie/laravel-image-optimizer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package laravel/framework (locked at v5.4.36, required as 5.7.*) is satisfiable by laravel/framework[v5.4.36] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Conclusion: don't install laravel/framework v5.7.28
    - Conclusion: don't install laravel/framework v5.7.27
    - Conclusion: don't install laravel/framework v5.7.26
    - Conclusion: don't install laravel/framework v5.7.25
    - Conclusion: don't install laravel/framework v5.7.24
    - Conclusion: don't install laravel/framework v5.7.23
    - Conclusion: don't install laravel/framework v5.7.22
    - Conclusion: don't install laravel/framework v5.7.21
    - Conclusion: don't install laravel/framework v5.7.20
    - Conclusion: don't install laravel/framework v5.7.19
    - Conclusion: don't install laravel/framework v5.7.18
    - Conclusion: don't install laravel/framework v5.7.17
    - Conclusion: don't install laravel/framework v5.7.16
    - Conclusion: don't install laravel/framework v5.7.15
    - Conclusion: don't install laravel/framework v5.7.14
    - Conclusion: don't install laravel/framework v5.7.13
    - Conclusion: don't install laravel/framework v5.7.12
    - Conclusion: don't install laravel/framework v5.7.11
    - Conclusion: don't install laravel/framework v5.7.10
    - Conclusion: don't install laravel/framework v5.7.9
    - Conclusion: don't install laravel/framework v5.7.8
    - Conclusion: don't install laravel/framework v5.7.7
    - Conclusion: don't install laravel/framework v5.7.6
    - Conclusion: don't install laravel/framework v5.7.5
    - Conclusion: don't install laravel/framework v5.7.4
    - Conclusion: don't install laravel/framework v5.7.3
    - Conclusion: don't install laravel/framework v5.7.2
    - spatie/laravel-image-optimizer 1.5.0 requires laravel/framework ~5.7.0|~5.8.0|^6.0 -> satisfiable by laravel/framework[v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.12, v5.7.13, v5.7.14, v5.7.15, v5.7.16, v5.7.17, v5.7.18, v5.7.19, v5.7.2, v5.7.20, v5.7.21, v5.7.22, v5.7.23, v5.7.24, v5.7.25, v5.7.26, v5.7.27, v5.7.28, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9].
    - Conclusion: don't install laravel/framework v5.7.1
    - Installation request for spatie/laravel-image-optimizer ^1.5 -> satisfiable by spatie/laravel-image-optimizer[1.5.0].
    - Conclusion: remove swiftmailer/swiftmailer v5.4.12
    - Conclusion: don't install swiftmailer/swiftmailer v5.4.12
    - laravel/framework v5.7.0 requires swiftmailer/swiftmailer ^6.0 -> satisfiable by swiftmailer/swiftmailer[v6.0.0, v6.0.1, v6.0.2, v6.1.0, v6.1.1, v6.1.2, v6.1.3, v6.2.0, v6.2.1].
    - Can only install one of: swiftmailer/swiftmailer[v6.0.0, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.0.1, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.0.2, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.1.0, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.1.1, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.1.2, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.1.3, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.2.0, v5.4.12].
    - Can only install one of: swiftmailer/swiftmailer[v6.2.1, v5.4.12].
    - Installation request for swiftmailer/swiftmailer (locked at v5.4.12) -> satisfiable by swiftmailer/swiftmailer[v5.4.12].


Installation failed, reverting ./composer.json to its original content
  • Вопрос задан
  • 42 просмотра
Пригласить эксперта
Ответы на вопрос 1
glaphire
@glaphire
PHP developer
Не может разрулить требования по версиям для spatie/laravel-image-optimizer, swiftmailer и laravel - там же все написано)
Надо апнуть swiftmailer (по packagist он уже давно ушел вперед), потом апнуть laravel до 5.7.0 и потом уже ставить laravel-image-optimizer.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы