numufar
@numufar
Системный администратор, эникейщик

Как настроить Mikrotik DSTNAT всего кроме одного поддомена?

Здравствуйте.
Есть Mikrotik RB1100AHx2. Есть сайт site.ru, который адресует на внешний айпи 1.1.1.1 (eth1 микрота). Но физически сайт лежит в другом месте 2.2.2.2 Соответственно микрот dstnat'ит всё, приходящее на 80 порт, туда.
Задача в том, что появился поддомен lk.site.ru, который также адресует на 1.1.1.1, но его нужно заворачивать на внутренний 192.168.0.100, а весь остальной трафик так же должен перенаправляться на 2.2.2.2
Попробовал настроить web-proxy на микроте, сделал редирект на него, прописал в статик днс site.ru(2.2.2.2) и lk.site.ru(192.168.0.100). Основной сайт работает, lk - нифига. Что я делаю не так, туда ли вообще копаю и что ещё можно придумать с этим?
  • Вопрос задан
  • 60 просмотров
Решения вопроса 1
poisons
@poisons
Что я делаю не так

Ты гвоздь гаечным ключем в металл закручиваешь. Reverse proxy....
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@dronmaxman
VoIP Administrator
Можно, но сложно. Если делать средствами микрота, то вопрос попадает в категорию сложных.

Необходи L7, перехват пакетов в сторону lk.site.ru и заворачивать таки пакеты в отдельную таблицу маршрутизации. К сожалению сейчас нет микрота под рукой чтобы протестить и написать как точно это сделать.
/ip firewall layer7-protocol
add name=site.ru regexp="^.+(lk.site.ru).*$"

/ip firewall mangle
add action=mark-connection chain=prerouting protocol=udp dst-port=80 connection-mark=no-mark layer7-protocol=site.ru new-connection-mark=site_conn assthrough=yes
add action=mark-packet chain=prerouting connection-mark=site_conn new-packet-mark=site_packet

Как-то так, но не уверен.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
16 окт. 2019, в 17:12
300 руб./за проект
16 окт. 2019, в 17:11
3000 руб./за проект
16 окт. 2019, в 17:07
3800 руб./за проект