@Givi777

Как запустить deploy на хостингу?

Помогите запустить envoy run deploy на хостингу ukraine
настроил ssh и ключи на bitbucket в итоге несколько ошибок

[itrevise@itrevise.ftp.tools]: Your requirements could not be resolved to an installable set of packages.
[itrevise@itrevise.ftp.tools]: Problem 1
[itrevise@itrevise.ftp.tools]: - This package requires php ^7.1.3 but your HHVM version does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 2
[itrevise@itrevise.ftp.tools]: - Installation request for doctrine/inflector v1.3.0 -> satisfiable by doctrine/inflector[v1.3.0].
[itrevise@itrevise.ftp.tools]: - doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 3
[itrevise@itrevise.ftp.tools]: - Installation request for dragonmantank/cron-expression v2.3.0 -> satisfiable by dragonmantank/cron-expression[v2.3.0].
[itrevise@itrevise.ftp.tools]: - dragonmantank/cron-expression v2.3.0 requires php ^7.0 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 4
[itrevise@itrevise.ftp.tools]: - Installation request for laravel/framework v5.8.35 -> satisfiable by laravel/framework[v5.8.35].
[itrevise@itrevise.ftp.tools]: - laravel/framework v5.8.35 requires php ^7.1.3 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 5
[itrevise@itrevise.ftp.tools]: - Installation request for nesbot/carbon 2.24.0 -> satisfiable by nesbot/carbon[2.24.0].
[itrevise@itrevise.ftp.tools]: - nesbot/carbon 2.24.0 requires php ^7.1.8 || ^8.0 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 6
[itrevise@itrevise.ftp.tools]: - Installation request for nikic/php-parser v4.2.4 -> satisfiable by nikic/php-parser[v4.2.4].
[itrevise@itrevise.ftp.tools]: - nikic/php-parser v4.2.4 requires php >=7.0 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 7
[itrevise@itrevise.ftp.tools]: - Installation request for paragonie/random_compat v9.99.99 -> satisfiable by paragonie/random_compat[v9.99.99].
[itrevise@itrevise.ftp.tools]: - paragonie/random_compat v9.99.99 requires php ^7 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 8
[itrevise@itrevise.ftp.tools]: - Installation request for swiftmailer/swiftmailer v6.2.1 -> satisfiable by swiftmailer/swiftmailer[v6.2.1].
[itrevise@itrevise.ftp.tools]: - swiftmailer/swiftmailer v6.2.1 requires php >=7.0.0 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 9
[itrevise@itrevise.ftp.tools]: - Installation request for symfony/console v4.3.4 -> satisfiable by symfony/console[v4.3.4].
[itrevise@itrevise.ftp.tools]: - symfony/console v4.3.4 requires php ^7.1.3 -> your PHP version (5.6.40) does not satisfy that requirement.
[itrevise@itrevise.ftp.tools]: Problem 10
[itrevise@itrevise.ftp.tools]: - Installation request for symfony/css-selector v4.3.4 -> satisfiable by symfony/css-selector[v4.3.4].
[itrevise@itrevise.ftp.tools]: - symfony/css-selector v4.3.4 requires php ^7.1.3 -> your PHP version (5.6.40) does not satisfy that requirement.

[✗] This task did not complete successfully on one of your servers.

на сервере поставил php 7.2
  • Вопрос задан
  • 122 просмотра
Пригласить эксперта
Ответы на вопрос 1
"your PHP version (5.6.40) does not satisfy that requirement" - я лишь вижу php 5.6
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
18 окт. 2019, в 23:45
150000 руб./за проект
18 окт. 2019, в 20:01
15000 руб./за проект