Установка новых компиляторов на CentOS6?

У меня есть Centos 6 версии, нужно собрать проект с флагом -std=gnu17, установлен devtoolset-2 но он не поддерживает стандарт 17, как быть?
  • Вопрос задан
  • 42 просмотра
Пригласить эксперта
Ответы на вопрос 2
jcmvbkbc
@jcmvbkbc
http://dilbert.com/strip/1998-08-24
Построить нужный компилятор с помощью crosstool-NG?
Ответ написан
CityCat4
@CityCat4
Кошки не похожи на людей, кошки - это кошки!
Собрать новый gcc. Вот только для EL6 обычно это mission impossible. EL6 - он уже достаточно стар и в нем устарело все. Поэтому для сборки нового gcc потребуется попутно собрать еще туеву хучу всякого.
Если нет идиосинкразии к systemd - переходить на EL7/EL8. Если есть - ну, тут искать самому, дистрибов без этого уродца немного.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы