@AlexxZhuravlev7

Как обновляться на Ubuntu, чтобы не сломать связку LEMP?

Вопрос такого характера: как мне обновлять Ubuntu только в плане безопасности, чтобы
php код дальше работал, как до обновлений, mysql, nginx.
  • Вопрос задан
  • 431 просмотр
Пригласить эксперта
Ответы на вопрос 4
ololopishpishrealne
@ololopishpishrealne
one|line|mega|pipe|ninja
По моему скромному мнению там ничего и не должно сломаться. Но если очень хочется есть механизм для того, чтобы не обновлять определенные пакеты.

dpkg
echo "%package-name% hold" | sudo dpkg --set-selections
echo "%package-name% install" | sudo dpkg --set-selections
dpkg --get-selections | grep %package-name%

apt
sudo apt-mark hold %package-name%
sudo apt-mark unhold %package-name%

aptitude
sudo aptitude hold %package-name%
sudo aptitude unhold %package-name%
Ответ написан
@feanor7
Системный администратор
Убунты под рукой нет, а проверьте у себя нет ли зависимости между deb пакетами mysql и php, ну и nginx и php. Это и будет Вам ответом, если deb не притянет новую версию, и новые библиотеки, то смена версии может повлечь смену синтаксис запросов.
Ответ написан
unwrecker
@unwrecker
Единственное, что не обладает в этой связке обратной совмнестимостью, это PHP. Но разные его версии имеют отдельные конфиги и сокеты для подключения (если только конфиги не очень старые и там порт вместо сокета). Так что бояться нечего
Ответ написан
zooks
@zooks
Frontend и Django
С nginx при обновлении не возникает проблем. Так что просто обновляйте.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы