Kens1n
@Kens1n
PHP и Joomla! разработчик

Как решить проблему Symfony «Fatal error: Class 'Doctrine\Bundle\FixturesBundle\DoctrineFixturesBundle' not found in»?

После добавления в composer двух новых библиотек
"require": {
"php": ">=5.3.9",
..... ,
"doctrine/doctrine-fixtures-bundle": "dev-master",
"doctrine/data-fixtures" : "dev-master"
}

Выполнения команды composer update, а затем при попытке в консоли выполнить выполнить команду "php app/console doctrine:fixtures:load" получаю ошибку "Ошибка Fatal error: Class 'Doctrine\Bundle\FixturesBundle\DoctrineFixturesBundle' not found in"

Содержимое консоли после composer update

composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for doctrine/data-fixtures dev-master -> satisfiable by doctrine/data-fixtures[dev-master].
- doctrine/data-fixtures dev-master requires php ^7.1 -> your PHP version (5.6.30) does not satisfy that requirement.
Problem 2
- symfony/framework-bundle v4.0.3 requires php ^7.1.3 -> your PHP version (5.6.30) does not satisfy that requirement.
- symfony/framework-bundle v4.0.2 requires php ^7.1.3 -> your PHP version (5.6.30) does not satisfy that requirement.
- symfony/framework-bundle v4.0.1 requires php ^7.1.3 -> your PHP version (5.6.30) does not satisfy that requirement.
- symfony/framework-bundle v4.0.0 requires php ^7.1.3 -> your PHP version (5.6.30) does not satisfy that requirement.
- Conclusion: don't install symfony/symfony v2.8.33
- Conclusion: don't install symfony/symfony v2.8.32
- Conclusion: don't install symfony/symfony v2.8.31
- Conclusion: don't install symfony/symfony v2.8.30
- Conclusion: don't install symfony/symfony v2.8.29
- Conclusion: don't install symfony/symfony v2.8.28
- Conclusion: don't install symfony/symfony v2.8.27
- Conclusion: don't install symfony/symfony v2.8.26
- Conclusion: don't install symfony/symfony v2.8.25
- Conclusion: don't install symfony/symfony v2.8.24
- Conclusion: don't install symfony/symfony v2.8.23
- Conclusion: don't install symfony/symfony v2.8.22
- Conclusion: don't install symfony/symfony v2.8.21
- Conclusion: don't install symfony/symfony v2.8.20
- Conclusion: don't install symfony/symfony v2.8.19
- Conclusion: don't install symfony/symfony v2.8.18
- Conclusion: don't install symfony/symfony v2.8.17
- Conclusion: don't install symfony/symfony v2.8.16
- Conclusion: don't install symfony/symfony v2.8.15
- Conclusion: don't install symfony/symfony v2.8.14
- Conclusion: don't install symfony/symfony v2.8.13
- Conclusion: don't install symfony/symfony v2.8.12
- Conclusion: don't install symfony/symfony v2.8.11
- Conclusion: don't install symfony/symfony v2.8.10
- Conclusion: don't install symfony/symfony v2.8.9
- Conclusion: don't install symfony/symfony v2.8.8
- Conclusion: don't install symfony/symfony v2.8.7
- Conclusion: remove symfony/symfony v2.8.6
- Conclusion: don't install symfony/symfony v2.8.6
- Conclusion: don't install symfony/symfony v2.8.5
- Conclusion: don't install symfony/symfony v2.8.4
- Conclusion: don't install symfony/symfony v2.8.3
- Installation request for doctrine/doctrine-fixtures-bundle dev-master -> satisfiable by doctrine/doctrine-fixtures-bundle[dev-master].
- Conclusion: don't install symfony/symfony v2.8.2
- Conclusion: don't install symfony/symfony v2.8.1
- doctrine/doctrine-fixtures-bundle dev-master requires symfony/framework-bundle ^3.3|^4.0 -> satisfiable by symfony/framework-bundle[v3.3.0, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.14, v3.3.15, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.1, v3.4.2, v3.4.3, v4.0.0, v4.0.1, v4.0.2, v4.0.3].
- symfony/framework-bundle v3.3.0 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.1 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.10 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.11 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.12 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.13 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.14 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.15 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.2 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.3 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.4 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.5 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.6 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.7 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.8 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.3.9 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.4.0 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.4.1 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.4.2 conflicts with symfony/symfony[v2.8.0].
- symfony/framework-bundle v3.4.3 conflicts with symfony/symfony[v2.8.0].
- Installation request for symfony/symfony 2.8.* -> satisfiable by symfony/symfony[v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.28, v2.8.29, v2.8.3, v2.8.30, v2.8.31, v2.8.32, v2.8.33, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
Содержимое composer.json

{
"name": "vitaliysborshikov/symfony_test",
"license": "proprietary",
"type": "project",
"autoload": {
"psr-4": {
"": "src/",
"Doctrine\\Bundle\\FixturesBundle\\": ""
},
"classmap": [
"app/AppKernel.php",
"app/AppCache.php"
]
},
"require": {
"php": ">=5.3.9",
"symfony/symfony": "2.8.*",
"doctrine/orm": "^2.4.8",
"doctrine/doctrine-bundle": "~1.4",
"symfony/swiftmailer-bundle": "~2.3",
"symfony/monolog-bundle": "~2.4",
"sensio/distribution-bundle": "~5.0",
"sensio/framework-extra-bundle": "^3.0.2",
"incenteev/composer-parameter-handler": "~2.0",
"doctrine/doctrine-fixtures-bundle": "dev-master",
"doctrine/data-fixtures" : "dev-master"
},
"require-dev": {
"sensio/generator-bundle": "~3.0",
"symfony/phpunit-bridge": "~2.7"
},
"scripts": {
"post-install-cmd": [
"Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::prepareDeploymentTarget"
],
"post-update-cmd": [
"Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile",
"Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::prepareDeploymentTarget"
]
},
"config": {
"bin-dir": "bin"
},
"extra": {
"symfony-app-dir": "app",
"symfony-web-dir": "web",
"symfony-assets-install": "relative",
"incenteev-parameters": {
"file": "app/config/parameters.yml"
},
"branch-alias": null
}
}

  • Вопрос задан
  • 336 просмотров
Решения вопроса 1
BoShurik
@BoShurik Куратор тега Symfony
Symfony developer
Вы не установили приведенные выше библиотеки:
Your requirements could not be resolved to an installable set of packages.


Решит проблему указание версии требуемой библиотеки (В вашем случае 2.3 совместима с Symfony 2.8):
"doctrine/doctrine-fixtures-bundle": "^2.3"
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы